To Fix this problem, simply increase your memory from 12MG to 64M in the virtual machine settings:

  1. Shutdown the guest machine
  2. Open the VirtualBox Manager (machine settings)
  3. Select the guest machine
  4. Go to the Display Tab
  5. Go to the Screen Tab
  6. In the Video Memory settings, change to 64M
  7. Click OK
  8. Done

Now start the guest machine and you will see the splash screen of your operating system. I had to do this because I recently installed Ubuntu 18tls and installed Guest Addtions, when I tried to resize the window it went blank. I tried everything until this trick worked.

TIP: It will also help if you set the following Display Settings:

Graphics Controller: VMSVGA

Accelartion: [x] Enable 3D Acceleration