The other day i was trying to install the Minalto Gallery for a customer. While doing the install, ( /install/index.php?step=2 ) on step 2, there was a warning that said:

Warning: Output buffering is enabled in your php by the output_buffering parameter(s) in php.ini. Gallery can function with this setting - downloading files is even faster - but Gallery might be unable to serve large files (e.g. large videos) and run into the memory limit. Also, some features like the progress bars might not work correctly if output buffering is enabled unless ini_set() is allowed.

When I looked into my php.ini file, the setting was set to:

output_buffering = 4096

I guess the gallery needed this to be disabled, so what i did, I set it to "Off" According to the instructions provided in the php.ini file:

; Output buffering allows you to send header lines (including cookies) even
; after you send body content, at the price of slowing PHP's output layer a
; bit. You can enable output buffering during runtime by calling the output
; buffering functions. You can also enable output buffering for all files by
; setting this directive to On. If you wish to limit the size of the buffer
; to a certain size - you can use a maximum number of bytes instead of 'On', as
; a value for this directive (e.g., output_buffering=4096).
output_buffering = 4096

I changed it to
output_buffering = Off

then I restarted my apache server


When I refreshed step two during the installation, i did get the warning, instead i got a SUCSESS

*if you have benefited from this post, we would appreciate a link back to - Why link back? by linking to wallpaperama, it will make this post more available for webmaster/people who are looking for answers to questions like this. - Thanks,